file2pacDep.plug.1rrp man page

file2pacDep.plug — a plugin for rpmrebuild, to change file dependencies into package dependencies

Synopsis

rpmrebuild --include file2pacDep.plug <packagename>
or
rpmrebuild --change-spec-requires="file2pacDep.sh [option]" <packagename>
the first form apply all changes
the second allow to choose which part to change, and plugin options

Description

this plugin is to replace all package's files dependencies to package dependencies.
For example, a dependency to /bin/bash will be changed to a dependency to bash package, the same for libraries.

Options

-f, --file
just apply changes on files with path (ex : /bin/bash)
-l, --lib
just apply changes on libraries file (ex : libc.so)
-h, --help
output help information about plugins option and exit.
-v, --version
print plugin version and exit
-V, --forceversion
add a dependency to current version (>=)

Files

file2pacDep.plug
is the 'include file' for a quicker use
file2pacDep.sh
contains the code
file2pacDep.plug.1
is this man page

Examples

"normal" rpm dependencies are :

$ rpm -qR rpm
gawk
fileutils
textutils
mktemp
shadow-utils
popt = 1.6.4
/bin/sh
/bin/sh
/bin/sh
rpmlib(CompressedFileNames) <= 3.0.4-1
ld-linux.so.2
libbz2.so.1
libc.so.6
libpopt.so.0
libpthread.so.0
librpm-4.0.4.so
librpmbuild-4.0.4.so
librpmdb-4.0.4.so
librpmio-4.0.4.so
librt.so.1
libz.so.1
/bin/sh
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.2.3)
libpthread.so.0(GLIBC_2.0)
librt.so.1(GLIBC_2.1)

now build a modified package:

rpmrebuild --include file2pacDep.plug rpm

and the result is :

$ rpm -qpR rpm-4.0.4-7x19.i386.rpm
rpmlib(VersionedDependencies) <= 3.0.3-1
popt = 1.6.4
bash
bzip2-libs
fileutils
gawk
glibc
mktemp
popt
rpm
shadow-utils
textutils
zlib
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

Authors

Eric Gerbier <gerbier@users.sourceforge.net>

See <URL:http://rpmrebuild.sourceforge.net/>.

Notes

this plugin is given as an example of what can be done

See Also

rpm(8), rpmbuild(8), rpmrebuild_plugins(1)
compat_digest.plug(1), demo.plug(1), demofiles.plug(1), nodoc.plug(1), uniq.plug(1), file2pacDep.plug(1) set_tag.plug(1) unset_tag.plug(1)
man -k rrp for plugins specific manpages

Info

2.11 Eric Gerbier rpmrebuild plugin